Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business


||-  Linux

|||-  

[Résolu] Pilotes Carte Graphique pour Linux

 

Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

[Résolu] Pilotes Carte Graphique pour Linux

Prévenir les modérateurs en cas d'abus 
Hayrosse_1
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 19/07/2007 à 19:01:42  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Salut à tous !

 Voilà, j'ai un petit problème, assez gênant tout de même.
 Je suis depuis peu sous Ubuntu 7.04, je débute donc sous linux.
 Le problème est que, ayant l'incapacité de me connecter sur internet chez moi, je ne peux installer à l'aide d'envy le pilote nécessaire à ma carte graphique : ATI Radeon X1300 Pro 256 Mo PCI-E. J'ai donc téléchargé chez mon grand-père (eh oui, on fait avec ce qu'on peut) le pilote en .run sur le site d'ATI (celui pour plate-forme 64 bits, comme ma version Ubuntu, mon processeur le prenant en charge) et j'ai essayé de suivre un tuto sur internet mais impossible de créer les fichiers .deb. J'ai déjà chercher sur internet et sur ce forum mais je n'ai pas trouvé mon bonheur. Je fais donc appelle à votre aide pour que je puisse enfin avoir en beau bureau en 1440x900 et pouvoir utiliser des applis 3D. Parce que là, c'est un peu moche et ça rame rien que pour un petit jeu de billard...
 J'aimerais, ou avoir les derniers pilotes mais pas en .run, ou avoir un moyen de convertir ce fichier pour l'installer.

 Merci d'avance.

niklavi2-0
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 19/07/2007 à 19:54:28  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
si je dis pas de connerie le .run s'installe seul.

 tu le rend executable

 $ chmod +x /ton_fichier.run
 ensuite tu le lances
 # /chemin_de_ton-fichier.run

(Publicité)
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 19/07/2007 à 20:09:22  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci de la réponse, je vais essayer.

hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 19/07/2007 à 20:51:15  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bon, ben linux me joue des tours : quand je tape comme tu m'a dit :

 chmod +x nom-du-pilote

 le terminal me dit que le fichier est introuvable, pourtant il est bel et bien sur mon bureau. Je comprends pas  :heink:
 Je pars essayer encore. Si tu as un peu plus à me dire, n'hésites pas.
 Merci

niklavi2-0
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 19/07/2007 à 20:58:29  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
$cd /home/user/Desktop
 /home/user/Desktop$ ls

 colle le résultat

(Publicité)
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 19/07/2007 à 21:09:25  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Voila ce que ça m'affiche :

 ati-driver-installer-8.39.4-x8​6.x86_64.run  nautilus-computer.desktop
 Corbeille.desktop                           nautilus-home.desktop

 c'est bien la preuve qu'il y est  :/  

niklavi2-0
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 19/07/2007 à 21:35:45  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
$ chmod +x /home/ton_nom_d'utilisateur/De​sktop/ati-driver-installer-8.3​9.4-x86.x86_64.run

 ensuite

 $ /home/ton_nom_d'utilisateur/De​sktop/ati-driver-installer-8.3​9.4-x86.x86_64.run

lognaume
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 19/07/2007 à 22:08:39  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
nik moi j'utilise sh driver.run ça fonctionne aussi ^^

(Publicité)
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 19/07/2007 à 22:12:17  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
J'ai fait la manip, voila ce qui s'affiche :

 imp3rial@imp3rial-desktop:~$ chmod +x /home/imp3rial/Desktop/ati-dri​ver-installer-8.39.4-x86.x86_6​4.run
 imp3rial@imp3rial-desktop:~$ /home/imp3rial/Desktop/ati-dri​ver-installer-8.39.4-x86.x86_6​4.run
 Created directory fglrx-install.J19328
 Verifying archive integrity... All good.
 Uncompressing ATI Proprietary Linux Driver-8.39.4.................​....................
 ==============================​====================
 ATI Technologies Linux Driver Installer/Packager
 ==============================​====================
 Detected configuration:
 Architecture: x86_64 (64-bit)
 X Server: X.Org 7.1 and later releases 64-bit
 Removing temporary directory: fglrx-install.J19328
 imp3rial@imp3rial-desktop:~$

 Mais rien ne se passe... je vais essayer d'installer les pilotes 32 bits de la même façon, cela marchera peut-être (j'avais pas vu mais c'est marqué sur le site d'ATI).

 Edit : Je viens d'essayer avec les pilotes 32 bits, même chose. Donc ça ne viens pas de là.
 Sinon, n'y aurait-il pas un autre moyen, même plus complexe à mettre en oeuvre ?
 Sachant que je ne peux pas connecter le linux à internet.

 Edit 2 : J'ai cherché un peu sur internet et j'ai trouvé un tuto explicatif : http://www.slyunix.org/astuce/astuce.php?a_id=228
 Je suis donc la méthode pour Ubuntu, mais voila l'erreur que cela m'affiche (je l'ai coloré en rouge) :

 imp3rial@imp3rial-desktop:~$ chmod +x /home/imp3rial/Desktop/ati-dri​ver-installer-8.39.4-x86.x86_6​4.run
 imp3rial@imp3rial-desktop:~$ LANG=C LC_ALL=C /home/imp3rial/Desktop/ati-dri​ver-installer-8.39.4-x86.x86_6​4.run --buildpkg Ubuntu/feisty
 Created directory fglrx-install.g26699
 Verifying archive integrity... All good.
 Uncompressing ATI Proprietary Linux Driver-8.39.4.................​.....................
 ==============================​====================
 ATI Technologies Linux Driver Installer/Packager
 ==============================​====================
 Generating package: Ubuntu/feisty
 Error: need root permissions or the `fakeroot' package installed

 Removing temporary directory: fglrx-install.g26699
 imp3rial@imp3rial-desktop:~$

 Comment avoir les "root permissions" ? Si je les ai, je pourrais surement continuer. Ou alors, devrais-je installer 'fakeroot', et si oui comment l'utiliser dans ce cas ? Merci encore d'avance.


tire mon doigt!
m3ta-x
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 20/07/2007 à 00:30:37  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Pour avoir la permission root (SuperUtilisateur) tape sudo devant ta commande.
 Ensuite ca te demandera ton mot de passe, tape le et ne t'inquiete pas si tu as l'impression d'ecrire dans le vide c'est normal, rien ne s'affiche quand tu tapes ton mot de passe ;) ) puis entrée, et voila, ta commande est executée en root :)

hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 20/07/2007 à 00:33:47  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci pour l'info M3ta-X, je testerai ça demain matin, là je vais me coucher  :sarcastic:
 J'espère que la nuit me portera conseil, et surtout chance  ;)

(Publicité)
niklavi2-0
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 20/07/2007 à 00:54:40  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

lognaume a écrit :

nik moi j'utilise sh driver.run ça fonctionne aussi ^^
 




 ouais moi aussi avant mais avec les .run c'est pas la peine de taper sh  ;)

lognaume
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 20/07/2007 à 10:02:04  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Tu as une méthode ici :
 http://doc.ubuntu-fr.org/materiel/ati_proprietaire
 Moi j'avais utilisé envy qui est super pratique mais apparamment instable sur feisty (7.04) :(

hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 21/07/2007 à 00:35:30  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci beaucoup pour cette réponse lognaume, mais hier soir par chance, j'ai trouvé les deb nécessaires sur le site des archives ubuntu, mais ce sont des pilotes ancien (8.24 au lieu des 8.39 actuels). Je les ai installés et j'ai enfin l'accélération 3D ! Le problème est que je n'arrive toujours pas a mettre la résolution adaptée a mon écran (a savoir, 1440x900), meme en tapant dans le terminal :

 aticonfig --resolution=0,1440x900,1024x7​68

 il me sort l'erreur suivante :

 error at set screen resolution : screen0 does not exist
 aticonfig: parsing the command-line failed.

 Je ne sais pas comment y remédier et avoir la bonne résolution autrement...
 En attendant, je vais mettre à jour les pilotes grace a ta méthode lognaume.
 Si quelqu'un à une solution, merci d'avance.

(Publicité)
Huhualenvers ?
fat115
Membre impliqué (de 20 000 à 29 999 messages postés)
  1. Posté le 21/07/2007 à 13:58:13  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
En console : sudo gedit /etc/X11/xorg.conf

 Copie le contenu dans un message, on te dira quelles modifs faire


---------------
Forum inutilisable => je suis parti ailleurs !
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 21/07/2007 à 15:11:22  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Voila, je l'ai tapé dans le terminal et ca me dit :

 (gedit:10688): GnomeUI-WARNING **: While connecting to session manager:
 Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

 et voici le fichier xorg.conf :


 # /etc/X11/xorg.conf (xorg X Window System server configuration file)
 #
 # This file was generated by dexconf, the Debian X Configuration tool, using
 # values from the debconf database.
 #
 # Edit this file with caution, and see the xorg.conf(5) manual page.
 # (Type "man xorg.conf" at the shell prompt.)
 #
 # This file is automatically updated on xserver-xorg package upgrades *only*
 # if it has not been modified since the last upgrade of the xserver-xorg
 # package.
 #
 # If you have edited this file but would like it to be automatically updated
 # again, run the following command:
 #   sudo dpkg-reconfigure -phigh xserver-xorg

 Section "ServerLayout"
  Identifier     "Default Layout"
  Screen         "Default Screen" 0 0
  InputDevice    "Generic Keyboard"
  InputDevice    "Configured Mouse"
  InputDevice    "stylus" "SendCoreEvents"
  InputDevice    "cursor" "SendCoreEvents"
  InputDevice    "eraser" "SendCoreEvents"
 EndSection

 Section "Files"

  # path to defoma fonts
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic​"
  FontPath     "/usr/share/fonts/X11/100dpi/:​unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:u​nscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-c​onf.d/dirs/TrueType"
 EndSection

 Section "Module"
  Load  "i2c"
  Load  "bitmap"
  Load  "ddc"
  Load  "dri"
  Load  "extmod"
  Load  "freetype"
  Load  "glx"
  Load  "int10"
  Load  "vbe"
 EndSection

 Section "InputDevice"
  Identifier  "Generic Keyboard"
  Driver      "kbd"
  Option     "CoreKeyboard"
  Option     "XkbRules" "xorg"
  Option     "XkbModel" "pc105"
  Option     "XkbLayout" "fr"
  Option     "XkbVariant" "oss"
 EndSection

 Section "InputDevice"
  Identifier  "Configured Mouse"
  Driver      "mouse"
  Option     "CorePointer"
  Option     "Device" "/dev/input/mice"
  Option     "Protocol" "ImPS/2"
  Option     "ZAxisMapping" "4 5"
  Option     "Emulate3Buttons" "true"
 EndSection

 Section "InputDevice"
  Identifier  "stylus"
  Driver      "wacom"
  Option     "Device" "/dev/input/wacom"
  Option     "Type" "stylus"
  Option     "ForceDevice" "ISDV4"# Tablet PC ONLY
 EndSection

 Section "InputDevice"
  Identifier  "eraser"
  Driver      "wacom"
  Option     "Device" "/dev/input/wacom"
  Option     "Type" "eraser"
  Option     "ForceDevice" "ISDV4"# Tablet PC ONLY
 EndSection

 Section "InputDevice"
  Identifier  "cursor"
  Driver      "wacom"
  Option     "Device" "/dev/input/wacom"
  Option     "Type" "cursor"
  Option     "ForceDevice" "ISDV4"# Tablet PC ONLY
 EndSection

 Section "Monitor"
  Identifier   "AL1916W"
  Option     "DPMS"
 EndSection

 Section "Device"
  Identifier  "Carte vidéo générique"
  Driver      "fglrx"
  Option     "DesktopSetup" "single"
  BusID       "PCI:5:0:0"
 EndSection

 Section "Screen"
  Identifier "Default Screen"
  Device     "Carte vidéo générique"
  Monitor    "AL1916W"
  DefaultDepth     24
  SubSection "Display"
   Depth     1
   Modes    "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
   Depth     4
   Modes    "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
   Depth     8
   Modes    "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
   Depth     15
   Modes    "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
   Depth     16
   Modes    "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
  SubSection "Display"
   Depth     24
   Modes    "1440x1440" "1400x1050" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
  EndSubSection
 EndSection

 Section "DRI"
  Mode         0666
 EndSection

 Section "Extensions"
  Option     "Composite" "0"
 EndSection

 Voili, voilou. Merci d'avance pour la solution  :super:

tire mon doigt!
m3ta-x
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 21/07/2007 à 17:39:56  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
rajoute ce qui est en gras ;)



SubSection "Display"
 Depth 1
 Modes "1440x1440" "1400x1050" "1440x900" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
 Depth 4
 Modes "1440x1440" "1400x1050" "1440x900" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
 Depth 8
 Modes "1440x1440" "1400x1050" "1440x900" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
 Depth 15
 Modes "1440x1440" "1400x1050" "1440x900" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
 Depth 16
 Modes "1440x1440" "1400x1050" "1440x900" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
 EndSubSection
 SubSection "Display"
 Depth 24
 Modes "1440x1440" "1400x1050" "1440x900" "1280x1280" "1280x1024" "1280x960" "1152x921" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"


hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 21/07/2007 à 18:46:54  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bon ben je viens d'ajouter les résolutions en gras comme tu m'a dit, mais toujours rien, lorsque je tape :

 aticonfig --resolution=0,1440x900,1024x7​68

 il me ressort l'erreur suivante :

 error at set screen resolution : screen0 does not exist
 aticonfig: parsing the command-line failed.

 Y a un blem, parce que lorsque je fais flgrxinfo, il me dit que l'écran s'appelle 0, mais là, il veut pas me le reconnaitre pour la résolution.  :(

Huhualenvers ?
fat115
Membre impliqué (de 20 000 à 29 999 messages postés)
  1. Posté le 22/07/2007 à 10:59:35  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Essaie de remplacer ton xorg.conf par celui-ci :
 



# /etc/X11/xorg.conf (xorg X Window System server configuration file)

 Section "ServerLayout"
 Identifier "Default"
 Screen "screen0" 0 0
 InputDevice "Generic Keyboard"
 InputDevice "Configured Mouse"
 EndSection

 Section "Files"

 # path to defoma fonts
 FontPath "/usr/share/fonts/X11/misc"
 FontPath "/usr/share/fonts/X11/cyrillic​"
 FontPath "/usr/share/fonts/X11/100dpi/:​unscaled"
 FontPath "/usr/share/fonts/X11/75dpi/:u​nscaled"
 FontPath "/usr/share/fonts/X11/Type1"
 FontPath "/usr/share/fonts/X11/100dpi"
 FontPath "/usr/share/fonts/X11/75dpi"
 FontPath "/var/lib/defoma/x-ttcidfont-c​onf.d/dirs/TrueType"
 EndSection

 Section "Module"
 Load "i2c"
 Load "bitmap"
 Load "ddc"
 Load "dri"
 Load "extmod"
 Load "freetype"
 Load "glx"
 Load "int10"
 Load "vbe"
 Load "dbe"
 EndSection

 Section "InputDevice"
 Identifier "Generic Keyboard"
 Driver "kbd"
 Option "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "fr"
 Option "XkbVariant" "oss"
 EndSection

 Section "InputDevice"
 Identifier "Configured Mouse"
 Driver "mouse"
 Option "CorePointer"
 Option "Device" "/dev/input/mice"
 Option "Protocol" "ImPS/2"
 Option "ZAxisMapping" "4 5"
 Option "Emulate3Buttons" "true"
 EndSection

 Section "Monitor"
 Identifier "AL1916W"
 Option "DPMS"
 EndSection

 Section "Device"
 Identifier "X1300Pro"
 Driver "fglrx"
 Option "DesktopSetup" "single"
 BusID "PCI:5:0:0"
 EndSection

 Section "Screen"
 Identifier "screen0"
 Device "X1300Pro"
 Monitor "AL1916W"
 DefaultDepth 24
 SubSection "Display"
 Depth 24
 Modes "1440x900"
 EndSubSection
 EndSection

 Section "DRI"
 Mode 0666
 EndSection

 Section "Extensions"
 Option "Composite" "0"
 EndSection




 Ensuite, tu redémarres le serveur X avec Ctrl+Alt+Backspace (ou tu rebootes à la windows).

 Pense à bien faire une sauvagarde de ton xorg.conf d'origine ;)


---------------
Forum inutilisable => je suis parti ailleurs !
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 22/07/2007 à 15:19:09  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Halleluia ! Merci Fat115, j'ai enfin la résolution 1440x900 ! Mais malheureusement, je n'ai plus l'accélération 3D. J'ai pourtant modifié le fichier /etc/modules, comme expliqué dans ce tuto :
 http://doc.ubuntu-fr.org/materiel/ati_proprietaire
 mais rien n'y fait. Je suis donc allé voir dans le gestionnaire de pilotes propriétaires et le pilote ATI est activé mais il n'est pas utilisé. Je ne sais pas comment faire pour qu'il soit utilisé et que l'accélération 3D revienne (si ca vient de là). C'est surement la dernière ligne droite, après je ne vous embêterai plus  ;) , sauf si ça ne marche toujours pas  :whistle: .

Huhualenvers ?
fat115
Membre impliqué (de 20 000 à 29 999 messages postés)
  1. Posté le 22/07/2007 à 17:13:39  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Que donne le retour de la commande lsmod | grep fglrx?


---------------
Forum inutilisable => je suis parti ailleurs !
tire mon doigt!
m3ta-x
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 22/07/2007 à 17:16:36  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Fat, rien a voir avec le sujet, mes les deux premiers liens dans ta signature tombent sur des sujets qui n'existent plus. je pense que tu le savais mais on sait jamais ^^

  1. config
secwineman
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 22/07/2007 à 17:23:37  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
POur installer les pilotes proprios sur ubuntu 7.04 il suffit d'aller dans le gestionaire de pilotes propriètaires et de cocher la case d'ati, puis de redémarrer :/  


---------------
Consulter mon profil LinkedIn
Legtux, hébergeur indépendant gratuit : sites web, mails, fichiers
tire mon doigt!
m3ta-x
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 22/07/2007 à 17:33:16  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

secwineman a écrit :

POur installer les pilotes proprios sur ubuntu 7.04 il suffit d'aller dans le gestionaire de pilotes propriètaires et de cocher la case d'ati, puis de redémarrer :/  
 




 Perso je trouve que c'est une trés bonne chose ce gestionnaire de pilotes proprios, mais pour Nvidia y'a des problemes, ca met pas les derniers drivers :-/
 Pour avoir ceux-ci on est obligé de passer par la console (mais bon en 15 secondes et 3 commandes c'est fini ^^)

  1. config
secwineman
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 22/07/2007 à 17:33:52  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

m3ta-X a écrit :

 


 Perso je trouve que c'est une trés bonne chose ce gestionnaire de pilotes proprios, mais pour Nvidia y'a des problemes, ca met pas les derniers drivers :-/
 Pour avoir ceux-ci on est obligé de passer par la console (mais bon en 15 secondes et 3 commandes c'est fini ^^)
 



 POur ati non plus c'est pas les derniers ^^


---------------
Consulter mon profil LinkedIn
Legtux, hébergeur indépendant gratuit : sites web, mails, fichiers
niklavi2-0
Assidu (de 10 000 à 19 999 messages postés)
  1. Posté le 22/07/2007 à 17:36:28  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
il me semble que le gestionnaire de pilotes proprio utilse internet pour les installer non?

tire mon doigt!
m3ta-x
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 22/07/2007 à 17:47:35  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Oui, ubuntu n'integre pas les pilotes proprios, pour des raisons de liberté je suppose

hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 22/07/2007 à 21:18:17  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bon ben j'ai l'impression que le sort joue contre moi : lsmod | grep fglrx ne retourne strictement rien. Et je sais bien que le gestionnaire installe les pilotes proprio par internet mais je ne peux pas connecter nunux à internet, je les ai installé manuellement, le blem maintenant c'est qu'ils sont activés dans le gestionnaire mais ils ne sont pas utilisés, et je ne saurais l'expliquer. Mais le fait est que je n'ai pas l'accélération 3D. Et, au risque de me répéter, lsmod | grep fglrx ne retourne rien... Je vais essayer de tripoter cette nuit est demain, mais je doute trouver la soluc seul, vu mon niveau... Merci encore pour votre aide jusqu'ici, j'en ai appri déjà pas mal, et au moins j'arrive à me dépatouiller un peu dans le terminal. Mais bon, c'est vrais qu'avoir la résolution et l'accélération 3D, ça serait plutot cool  :sarcastic:

Huhualenvers ?
fat115
Membre impliqué (de 20 000 à 29 999 messages postés)
  1. Posté le 23/07/2007 à 09:19:19  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
si lsmod | grep fglrx ne retourne rien, c'est que le module fglrx (donc le pilote proprio ati) n'est pas chargé.

 Essaie un sudo modprobe fglrx, pour voir ce que ça retourne



 PS : m3ta-X, merci pour l'info, je n'y avais pas pensé en supprimant les sujets en question ;)


---------------
Forum inutilisable => je suis parti ailleurs !
lapin-fou
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 23/07/2007 à 10:56:04  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

m3ta-X a écrit :

Oui, ubuntu n'integre pas les pilotes proprios, pour des raisons de liberté je suppose
 



 m'ouai... le kernel d'ubuntu intègre des firmwares proprio. ça a d'ailleurs généré pas mal de discussion enflammées au début. alors la liberté sous ubuntu...

 si tu veux du 100% libre faut regarder du côté de debian (et de certaines versions de distro genre la free de mandriva) mais ubuntu n'est pas entièrement libre.


---------------
Parsix Linux: http://parsix.org
hayrosse_1
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 23/07/2007 à 12:57:22  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bon, j'ai une excellente nouvelle à vous annoncer. Ce matin, j'ai réussi à faire accepter au gestionnaire d'utiliser les pilotes proprio, mais il m'a fallu les désinstaller puis les réinstaller d'une certaine façon, d'abord pour avoir l'accélération, puis j'ai modifié le xorg.conf par celui que m'a gentiment indiqué fat115, et là tout à baigné, j'avais aussi la résolution  :super: !
 Puisque c'est maintenant réglé je vais passer le sujet en résolu, mais je pensais faire un petit tuto pour expliquer comment j'ai procédé dans les détails et aider ceux qui seraient dans mon cas (pas possible d'avoir internet pour linux), mais est-ce que vous trouvez que ça peut-etre utile ? Si oui, j'aurais besoin de ton aide fat115 pour expliquer comment modifié correctement le xorg.conf selon le cas, puis tu pourrais vérifier le tuto pour voir si je n'ai pas écrit de bêtises  ;) . Tout ça si tu est d'accord biensûr :sarcastic: .
 Voilou, merci encore à tous pour votre aide et pour l'intérêt que vous avez montré pour mon problème.

Huhualenvers ?
fat115
Membre impliqué (de 20 000 à 29 999 messages postés)
  1. Posté le 23/07/2007 à 14:54:24  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Toute information peut aider ;)

 en ce qui concerne les modifications du xorg.conf, c'est tout simple :
 1/ j'ai viré les infos concernant une éventuellem tablette graphique wacom (dans ServerLayout et les sections InputDEvice associées)
 2/ j'ai rajouté l'extension "dbe" (Double Buffer Extension)
 3/ j'ai viré tout le fatras concernant les différentes résolutions supportées par la carte pour ne laisser qu'une section avec le nombre de couleur max (profondeur de couleur : 24 bits) et une seule résolution, la résolution native de ton LCD
 4/ au passage, j'ai renommé l'écran en screen0 au lieu de "Default Screen" pour simplifier mais c'est purement cosmétique

 En fait, seule l'étape 3 est nécessaire :D


---------------
Forum inutilisable => je suis parti ailleurs !
 Page :
1

Aller à :
 

Sujets relatifs
[Topikatroll] Windows vs Linux help pour config serveur graphique...
désinstallation pilotes nvidia (résolu) probleme mon pc ne lit pas ma carte sd (résolu)
RESOLU Acces au disque dur refusé Problème installation DirectX [Résolu]
pc redemarre tout seul [resolu] netvibes et google [Résolu]
Plus de sujets relatifs à : [Résolu] Pilotes Carte Graphique pour Linux