Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business



|||-  

Excel : moyenne impossible à calculer

 

Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

Excel : moyenne impossible à calculer

Prévenir les modérateurs en cas d'abus 
rouky31
rouky31
  1. Posté le 11/07/2007 à 15:45:47  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,
 Cela fait plusieurs jours que je bute sur un problème de calcul de moyenne avec excel :hurle: . Ne connaissant rien en VBA, je souhaite ne me servir que de fonctions. J'explique mon problème :
 En feuille 1 :dans la colonne A, j'ai des noms de personnes, et dans la colonne B, des notes correspondantes. Il faut savoir qu'un même nom peut revenir plusieurs fois, et que chaque nom n'a pas necessairement une note.Cela ressemble à ça :

 Pierre    4
 Paul      3
 Jacques   1
 Pierre    
 Jacques   5

 Je souhaite alors en feuille 2, après avoir affiché la liste des noms sans doublons (en colonneA) par un filtre élaboré, calculer la moyenne de chacun.
 Il semble y avoir un problème quand une cellule est vide, c'est à dire quand un nom n'a pas de note.La formule que j'ai trouvé ne marche pas :

 =(SOMMEPROD((Feuil1!$A$2:$A$6=​Feuil2!A5)*(Feuil1!$B$2:$B$6))​)/NB.SI(Feuil1!$A$2:$A$6;Feuil​2!A5)

 Voila, j'espère avoir été le plus clair possible :heink: . Pouvez-vous m'aider svp, ça m'enleverait une grosse épine du pied. Merci d'avance

michel_m
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 11/07/2007 à 16:02:14  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,

 une solution par matricielle (je l'ai testée sur la m^feuille)
 =MOYENNE(SI((A$1:A$5=D1)*(B$1:​B$5<>"" );B$1:B$5))
 a valider par Ctrl+maj+entrée

 edit:
 Tu pourrais aussi utiliser les tableaux croisés dynamiques


---------------
Amicalement Michel
(Publicité)
gorfael
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 11/07/2007 à 22:04:52  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

rouky31 a écrit :

Bonjour,
 Cela fait plusieurs jours que je bute sur un problème de calcul de moyenne avec excel :hurle: . Ne connaissant rien en VBA, je souhaite ne me servir que de fonctions. J'explique mon problème :
 En feuille 1 :dans la colonne A, j'ai des noms de personnes, et dans la colonne B, des notes correspondantes. Il faut savoir qu'un même nom peut revenir plusieurs fois, et que chaque nom n'a pas necessairement une note.Cela ressemble à ça :

 Pierre    4
 Paul      3
 Jacques   1
 Pierre    
 Jacques   5

 Je souhaite alors en feuille 2, après avoir affiché la liste des noms sans doublons (en colonneA) par un filtre élaboré, calculer la moyenne de chacun.
 Il semble y avoir un problème quand une cellule est vide, c'est à dire quand un nom n'a pas de note.La formule que j'ai trouvé ne marche pas :

 =(SOMMEPROD((Feuil1!$A$2:$A$6=​Feuil2!A5)*(Feuil1!$B$2:$B$6))​)/NB.SI(Feuil1!$A$2:$A$6;Feuil​2!A5)

 Voila, j'espère avoir été le plus clair possible :heink: . Pouvez-vous m'aider svp, ça m'enleverait une grosse épine du pied. Merci d'avance
 


Salut à tous
 J'ai refait ta formule, et j'ai 4 comme résultat pour Pierre
 J'ai fait un copier/coller de ta formule et j'ai 2  :??:

 Donc, si quelqu'un peut m'expliquer, j"aimerais savoir pourquoi m'enfin  :beubeub:

 Pour faire une moyenne, et qu'elle soit représentative des notes, il y a le problème de la note vide. Excel lors d'un calcul conveti vide en 0. Donc, par principe, je préfére lever toute ambiguïté à se sujet, et donc ma formule serait plutot :
 =SOMMEPROD((Feuil1!$A$2:$A$6=F​euil2!A5)*Feuil1!$B$2:$B$6)/SO​MMEPROD(NON(ESTVIDE(Feuil1!$B$​2:$B$6))*(Feuil1!$A$2:$A$6=Feu​il2!A5))
 A+

michel_m
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 12/07/2007 à 09:50:16  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
salut Gorfael

 c'est normal que Pierre ait 4 de moyenne puisqu'il est noté qu'une seule fois: tu as confondu "vide" et "zéro"; si tu mets 0 à la 2° occurence de Pierre tu obtiendras 2 de moyenne... :fume:
 En effet, dans les fonctions syatistiques comme moyenne, écart-type, Excel fait la différence entre "vide" et "zéro"; de même, tu peux avoir du texte sans que cela renvoie "valeur"

 Quant au copier-coller de ce forum, cela m'a fait le coup du zéro plusieurs fois: peut-être un problème de format


---------------
Amicalement Michel
rouky31
  1. Posté le 12/07/2007 à 15:58:25  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci enormement michel_m .
 Tes 2 solutions sont bonnes. Vu que c'est un fichier destiné à des novices, enfin un peu plus que moi, j'ai opté pour les tableaux dynamiques que je ne connaissais pas. Tu m'as fait découvrir là un outil énorme !!!
 Encore un grand merci :D

(Publicité)
 Page :
1

Aller à :
 

Sujets relatifs
excel : formule pour calculer mes heures de travail Lenteur ouverture documents par double clic sur Word Excel
Excel : texte remplacé par ##### Lien hypertexte Excel
Comment copier un tableau Excel dans un PPS PB avec DivX Plus (désinstallation impossible)
vitesse moyenne de download sur une session  
Plus de sujets relatifs à : Excel : moyenne impossible à calculer