Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business



|||-  

Excel 2010 : conditions avec sommeprod et nb.si.ens mal respectées

 

2 utilisateurs anonymes
Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

Excel 2010 : conditions avec sommeprod et nb.si.ens mal respectées

Prévenir les modérateurs en cas d'abus 
JulietteMr​r
juliettemrr
  1. Posté le 09/08/2016 à 16:07:09  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour à tous,

J'ai besoin de construire des statistiques à partir d'une base de données qui indique des informations notamment en fonction d'heures et de jours de la semaine.
Précisément, j'aimerais compter le nombre de lignes dont le jour est lundi et en fonction des tranches horaires.

Avec en B45 : 7:30
en C5 : 8:00


J'ai utilisé les formules suivantes (exemples avec une tranche d'horaire random) :
- =SOMMEPROD((Tableau1[Jour]="lundi" )*(Tableau1[Heure]>B5)*(Tableau1[Heure]​<C5))
- =NB.SI.ENS(Tableau1[Jour];"lundi";Tablea​u1[Colonne1];B5;Tableau1[Colon​ne1];C5)


Quand je fais la somme de toutes ces données ainsi trouvées (donc le nombre de lignes totales dont le jour est lundi), cela me donne 3267 alors qu'il y en a en réalité 3248.

J'ai aussi essayé de tester les formules avec comme critères >=7:30 et <=7:59 et là cela me donne 3233 lignes totales pour le lundi !!

Il y a donc une erreur que j'aimerais corriger mais je n'arrive pas à savoir d'où elle vient... :??:

Merci d'avance de votre aide !

willyplaisir
Expert Excel Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 09/08/2016 à 19:52:34  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
bsr

as tu appliqué le CTR+Maj+Entrée pour tes formules en calcul Matriciel
et divisé le temps par 24h

voir ce fichier démo
http://www.cjoint.com/c/FHjsXR​ecjkW

sinon tu déposes ton fichier enregistré sur une ancienne version d'Excel (2003 ou 2007)sur le forum pour tester

 :hello:
Message édité par willyplaisir le 09/08/2016 à 19:54:25

---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
(Publicité)
juliettemrr
  1. Posté le 10/08/2016 à 08:37:38  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour willyplaisir et merci beaucoup de ta réponse,

Voici le fichier dont je parle : http://www.cjoint.com/c/FHkhIO​GyOt5

Peux-tu préciser ce dont tu parles avec le "ctrl+maj+entrée" ? Et oui j'ai testé aussi en divisant le temps par 24h mais cela ne change rien, le problème persiste. Donc j'en ai conclu que le problème ne venait pas de là.

willyplaisir
Expert Excel Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 10/08/2016 à 11:26:13  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bjr

Je vois que tu as 16 doublons faut-il ajouter un autre critère?
voir le fichier
http://www.cjoint.com/c/FHkkwQ​SgDGW

 :hello:


---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
juliettemrr
  1. Posté le 10/08/2016 à 13:28:09  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Holala merci merci merci !!!!! :love:

Avez-vous une idée de la formulation d'un autre critère qui dirait "si la date est différente" ou juste qui tiendrait compte de la date pour éviter que l'erreur ne se reproduise ?

(Puis-je juste vous poser une question : comment êtes-vous arrivé à maîtriser si bien Excel, est-ce pour votre métier, grâce à votre formation/études...?)

Encore merci !

(Publicité)
juliettemrr
  1. Posté le 10/08/2016 à 13:42:36  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Je viens de remarquer que juste en retapant "15:30" en B20, "16:00" en C20, "17:00" en B23 et "17:30" en C23, le 2205 de la cellule D31 repasse à 2218 c'est-à-dire le bon résultat... Je ne comprends pas, est-ce à dire que les erreurs proviennent d'un bug du logiciel ? :??:

willyplaisir
Expert Excel Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 10/08/2016 à 14:15:46  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Je pense que Oui, les programmeurs de Microsoft ne sont pas infaillibles, j'ai déjà constaté des bugs dans certaines commandes en VBA souvent avec les dates.

bug sur le format 00:00:00 pour certaines heures
il suffit d'ajouter 1s pour trouver la bonne valeur

http://www.cjoint.com/c/FHkrat​ktcyW

Pour répondre à ta question, j'ai une formation en physique Nucléaire et j'utilise Excel depuis la 1ère Version, puis j'appris le langage VBA pour automatiser tous mes nombreux calculs scientifiques dans mes rapports.

J'aide les internautes sur ce forum et un autre en maths.

Bonne journée
willy

Si tu as le temps de visiter les 2 associations ci jointes ce serait sympa et éventuellement leur faire un don pour l'aide apportée à ta demande.Merci
 :hello:
Message édité par willyplaisir le 10/08/2016 à 18:03:39

---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
juliettemrr
  1. Posté le 11/08/2016 à 13:16:58  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci beaucoup pour tes réponses willyplaisir !
Je passerai sur les pages de ces asso :)

(Publicité)
willyplaisir
Expert Excel Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 11/08/2016 à 13:29:35  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci de penser aux chats abandonnés

 :hello:


---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
 Page :
1

Aller à :
 

Sujets relatifs
erreur 0xc0000022 pour word ou excel 16 sous Windows 10 Equivalent à EXCEL 2010 ?
Excel : nom de la feuille dans une cellule EXCEL - trier une liste avec des images insérées
Excel - Sommeprod Comment fusionner un document Word avec Excel ?
excel : formule pour calculer mes heures de travail  
Plus de sujets relatifs à : Excel 2010 : conditions avec sommeprod et nb.si.ens mal respectées