Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business

|-  LOGICIELS

||-  Linux

|||-  

drivers nvidia sous debian 4.1

 

68 utilisateurs inconnus
Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

drivers nvidia sous debian 4.1

Prévenir les modérateurs en cas d'abus 
ragueubuff
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 15:43:24  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,


 Je n'arrive pas à installer les drivers nvidia pour avoir l'accélération 3d de ma geforce 7900 GT. Je suis allé sur ouatmille forum et j'ai lu pleins de tuto (sur le site de nvidia, sur d'autres forums etc....) et rien n'y fait. aucune méthode n'est fiable. Il manque toujours un paquet et la seule indication pour le trouver est "fait un apt-get...." sans préciser le dépot (et bien sur synaptic ne le trouve pas dans le dépôt debian de base qui est le seul que je connais).
 J'ai essayé de lancer le .run de nvidia, ça va jusqu'au bout, ça pousse la perversion à me dire que ça a marché et........... en fait non.

 Alors si vous avez réussi à les installer comment avez vous fait? Je désespère là, j'ai passé une journée à suivre pleins de trucs et j'aimerais vraiment que ça finisse par marcher!

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 17:20:54  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Je te conseille d'oublier l'installateur du site d'nvidia et d'installer ces driver avec module-assistant.


 Il faut:
 -> activer les source non libre
 -> # apt-get install module-assistant
 -> # m-a a-i nvidia

 -> changer dans le fichier xorg.conf  nv par nvidia.

 Il y a plein de tuto sur le net mais regarde ceux qui utilisent module-assistant
 edit: par exemple  http://www.andesi.org/index.php?node=83
 1°  sais tu éditer une fichier sans x ? (avec nano ou vim par exemple)


---------------
gnu/debian lenny kernel 2.6.32
(Publicité)
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 17:43:24  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
je sais éditer sans x avec nano oui mais néanmoins je ne sais pas comment activer les sources non libres....

ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 18:04:01  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
je suis allé voir ton tuto et j'ai fait cette commande:

 m-a build nvidia-kernel-source

 la réponse est:

 The source tarball could not be found!
 Package nvidia-kernel-source not installed?
 Running "m-a -f get nvidia-kernel-source" may help.
 find: /usr/src/modules: Aucun fichier ou répertoire de ce type


 pourtant j'ai bien fait attention à télécharger nvidia-glx et j'avais bien activé le non free (car j'ai trouvé comment faire entre temps) via la ligne
 deb ftp://ftp.fr.debian.org/debian​/ etch main contrib non-free

 je ne sais vraiment plus quoi faire, avant ça j'avais déjà testé pleins de tuto.... ça marche jamais..........

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 18:19:24  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

ragueubuff a écrit :

je sais éditer sans x avec nano oui mais néanmoins je ne sais pas comment activer les sources non libres....
 


Il faut éditer en root le fichier /etc/apt/sources.list  et rajouter non-free

 par exemple pour ma lenny j'ai



deb http://ftp.fr.debian.org/debian lenny main contrib non-free
 deb-src http://ftp.fr.debian.org/debian/ lenny main contrib non-free
 



 # apt-get update    (pour prendre en compte les changements)

 ensuite
 # apt-get install module-assistant
 # m-a a-i nvidia
 # changer dans xorg.conf nv par nvidia
 et normalement ca doit être bon


---------------
gnu/debian lenny kernel 2.6.32
(Publicité)
  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 18:23:01  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
j'ai lu ton deuxième message après.

 il faut avant de compiler le télécharger le paquet source des drivers nvidia

 tape simplement #  m-a a-i nvidia  ou # m-a a-i nvidia-kernel-source    (je ne sais plus)


 edit: as tu bien fait # apt-get update?


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 18:43:08  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
j'ai bien fait un apt-get update, je viens de le refaire pour etre sur....

 j'ai tapé m-a a-i nvidia puis  m-a a-i nvidia-kernel-source et dans les deux cas une fenêtre bleuatre s'ouvre et m'annonce fièrement que " La construction du paquet nvidia-kernel-source a échoué" puis crache dans la console :

 



Données de 1 paquets mises à jour
 Récupération des sources du noyau de la version : 2.6.18-6-686
 En-têtes du noyau disponibles dans /lib/modules/2.6.18-6-686/buil​d
 apt-get install build-essential
 Lecture des listes de paquets... Fait
 Construction de l'arbre des dépendances... Fait
 build-essential est déjà la plus récente version disponible.
 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

 Fait.
 unpack
 The source tarball could not be found!
 Package nvidia-kernel-source not installed?
 Running "m-a -f get nvidia-kernel-source" may help.
 "/usr/share/modass/packages/de​fault.sh" build KVERS=2.6.18-6-686 KSRC=/lib/modules/2.6.18-6-686​/build KDREV=2.6.18.dfsg.1-18etch1 kdist_image
 find: /usr/src/modules: Aucun fichier ou répertoire de ce type




 et..... voilà!

 Donc télécharger le paquet source... je fais ça comment? Je le trouve où? Et je le met où ensuite? Il y a un répertoire précis?

 par ailleurs il me dit un truc genre



Le paquet nvidia-kernel-source n'a pas pu être construit, voir  /var/cache/modass/nvidia-kerne​l-source*buildlog* pour plus de détails.  




 je suppose que c'est ce qu'on appelle un "log" mais j'ai essayé de lire ce fichier et je ne sais pas comment faire....

 Franchement c'est chaud là. si tu dépannes ça tu es mon idole, j'en ai trop marre....

ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 18:53:41  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
hmmm alors en examinant cette ligne là "/usr/src/modules no such file or directory" je viens de voir que dans mon /usr/src jh'ai un fichier nvidia-kernel.tar.bz2, sont ce les fameuses sources du noyau? mais effectivement je n'ai pas de répertoire /usr/src/modules, est ce un problème?

(Publicité)
  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 19:05:08  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
oui absolument mais normalement il doit être crée.
 il manque à mon avis des paquets.

 -> est que tu as bien les headers qui correspond  à ton noyau?

 $ uname -r (pour  la version noyau)
 $ apt-cache search  linux-headers  | grep `uname -r`
 tu installes le paquet tu obtiens.

 -> as tu bien installé build-essential ?


 -> Sinon on le fait à la main sinon
 # cd /usr/src/
 # mkdir modules
 #  cd modules
 # tar jxvf ../nvidia-kernel.tar.bz2  (utilise la tabulation)


---------------
gnu/debian lenny kernel 2.6.32
  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 19:08:14  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
quand tu utilises m-a  normalement quand il y a une erreur on te propose de lire le fichier log et avec la flèche "down" tu lis le fichier log.

 Sinon il est ici /var/cache/modass/nvidia-kerne​l-source  alors il te suffit de l'éditer pour le lire


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 19:13:03  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
apt-cache search linux-headers | grep `uname -r` donne:

 linux-headers-2.6.18-6-686 - Header files for Linux 2.6.18 on PPro/Celeron/PII/PIII/P4
 linux-headers-2.6.18-6-686-big​mem - Header files for Linux 2.6.18 on PPro/Celeron/PII/PIII/P4


 apt-get install build-essential donne:

 Lecture des listes de paquets... Fait
 Construction de l'arbre des dépendances... Fait
 build-essential est déjà la plus récente version disponible.
 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

 après avoir crée le répertoire et détarrer les sources dedans... ben en faisant m-a a-i nvidia puis m-a a-i nvidia-kernel-source, ça marche tjr pas.
 J'ai ça:
 "Données de 1 paquets mises à jour
 Récupération des sources du noyau de la version : 2.6.18-6-686
 En-têtes du noyau disponibles dans /lib/modules/2.6.18-6-686/buil​d
 apt-get install build-essential
 Lecture des listes de paquets... Fait
 Construction de l'arbre des dépendances... Fait
 build-essential est déjà la plus récente version disponible.
 0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

 Fait.
 unpack
 The source tarball could not be found!
 Package nvidia-kernel-source not installed?
 Running "m-a -f get nvidia-kernel-source" may help.
 "/usr/share/modass/packages/de​fault.sh" build KVERS=2.6.18-6-686 KSRC=/lib/modules/2.6.18-6-686​/build KDREV=2.6.18.dfsg.1-18etch1 kdist_image
 "

(Publicité)
  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 19:28:52  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
#  apt-get install linux-headers-2.6.18-6-686

 Il faut aussi un lien symbolique qui pointe vers tes headers
 Normalement il est fait automatiquement avec m-a
 remarque tape juste # m-a   (tu peux mettre à jour installer etc...)


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 20:13:32  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

limax a écrit :

#  apt-get install linux-headers-2.6.18-6-686

 Il faut aussi un lien symbolique qui pointe vers tes headers
 Normalement il est fait automatiquement avec m-a
 remarque tape juste # m-a   (tu peux mettre à jour installer etc...)
 




 alors, j'ai fait le lien symbolique et ça a marché, du coup j'ai fait la suite et... ça a presque marché!

 Mais bon je suis enthousiaste, c'est déjà un début.

 voilà ce que j'ai fait comme série de commandes exactement:

 [code]
 apt-get install linux-headers-`uname -r`
 apt-get install module-assistant gcc nvidia-kernel-common build-essential
 m-a update
 m-a prepare
 m-a auto-install nvidia
 apt-get install nvidia-glx
 modprobe nvidia
 dpkg-reconfigure -phigh xserver-xorg
 [/code]

 et bon, donc au moins les m-a ont marchés mais là j'ai pas l'impression d'avoir la 3D, car quand je fais:

 [code]
 glxinfo | grep rendering
 [/code]

 j'obtiens:

 [code]
 Xlib:  extension "GLX" missing on display ":0.0".
 Xlib:  extension "GLX" missing on display ":0.0".
 Xlib:  extension "GLX" missing on display ":0.0".
 Error: couldn't find RGB GLX visual
 Xlib:  extension "GLX" missing on display ":0.0".
 Xlib:  extension "GLX" missing on display ":0.0".
 Xlib:  extension "GLX" missing on display ":0.0".
 Xlib:  extension "GLX" missing on display ":0.0".
 [/code]

 ce qui ne me semble pas très engageant.... et j'ai remarqué que la plupart des écrans de veille openGL ne marchent pas, du coup il me semble bien que ça a marché mais... pas de bol pas de 3D!

 Que faire?

 Besoin d'autres infos? ?

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 20:35:40  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
pour savoir si le module est chargé $ lsmode |  nvidia

 ensuite il faut regarder les log pour regarder où est le problème, ca se trouve ici:  /var/log/Xorg.0.log


 est ce que tu as le logo nvidia au démarage?

 est que tu as bien le driver nvidia (et pas nv) dans ton xorg.conf ?


---------------
gnu/debian lenny kernel 2.6.32
(Publicité)
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 20:53:03  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

limax a écrit :

pour savoir si le module est chargé $ lsmode |  nvidia

 ensuite il faut regarder les log pour regarder où est le problème, ca se trouve ici:  /var/log/Xorg.0.log


 est ce que tu as le logo nvidia au démarage?

 est que tu as bien le driver nvidia (et pas nv) dans ton xorg.conf ?
 




 alors: voilà le résultat du lsmod

 



 

 nvidia               7815200  0
 agpgart                29896  2 nvidia,intel_agp
 i2c_core               19680  2 nvidia,i2c_i801

 




 je suis moins chanceux avec le log

 



 

 more var/log/Xorg.0.log
 var/log/Xorg.0.log: Aucun fichier ou répertoire de ce type

 




 je n'ai pas le logo nvidia au démarrage.

 après vérification dans /etc/X11/xorg.conf j'ai remarqué que c'est "nv" qui est marqué et pas "nvidia" du coup j'ai remplacé par "nvidia" mais là ça foire, le serveur se lance pas et me dit qu'il ne trouve pas le driver.

ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 21:18:36  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
dans un autre forum on m'a demandé de faire un ls -l /etc/X11/xorg.conf*
 je ne sais pas trop pourquoi mais voilà le résultat si cela pouvait t'aider:

 -rw-r--r-- 1 root root 3524 2008-02-12 20:49 /etc/X11/xorg.conf
 -rw-r--r-- 1 root root 4311 2008-02-12 19:34 /etc/X11/xorg.conf.20080212193​421
 -rw-r--r-- 1 root root 3351 2008-02-12 19:41 /etc/X11/xorg.conf.20080212194​104
 -rw-r--r-- 1 root root 3475 2008-02-12 19:52 /etc/X11/xorg.conf.20080212195​228
 -rw-r--r-- 1 root root 4313 2008-02-12 19:58 /etc/X11/xorg.conf.20080212195​846
 -rw-r--r-- 1 root root 3529 2008-02-12 19:54 /etc/X11/xorg.conf.backup

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 21:40:16  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
pas de logo donc le module ne semble pas compilé, donc  refait
 # m-a a-i -i -t -f nvidia-kernel
 # depmod -a

 personnellement je tape juste # m-a puis je suis les menus.
 tu remets nvidia à la place de nv puis tu rebootes

 si tu as encore des problèmes:
 # lsmode | grep nvidia (pour vérifier si le module est chargé)
 # modeprobe nvidia (pour charger le module)
 $ startx  (pour lancer une session x .


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 21:59:31  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
SAMARCHPAS

 voilà ce que donne le log:

 



 

 cat /var/log/Xorg.0.log | grep EE

 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 (II) Loading extension MIT-SCREEN-SAVER
 (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

 




 Pourtant je comprend pas....
 j'ai fait ça:

 



 

 # m-a a-i -i -t -f nvidia-kernel
 # depmod -a

 




 puis j'ai remplacé "nv" par "nvidia" dans xorg.conf avant de relancer le serveur X et là ça marche pas....
 Qu'est-ce qui se passe?

 après ça quand je fais un lsmod|grep nvidia j'ai ça actuellement:

 



 
 nvidia               7815200  0
 agpgart                29896  2 nvidia,intel_agp
 i2c_core               19680  2 nvidia,i2c_i801
 




 rahhhhhhhhhhh!!!

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 12/02/2008 à 22:12:19  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
fais tu parti du groupe video?  #  adduser tonuser  video

 que donne: # cat /var/log/Xorg.0.log | grep WW

 sinon met tout le fichier ici.



---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 22:23:51  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
j'appartiens bien au groupe video...

ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 12/02/2008 à 22:24:41  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
j'appartiens déjà au groupe vidéo.

 Voilà pour le log:


 cat /var/log/Xorg.0.log | grep WW

(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/misc​" does not exist.
 (WW) The directory "/usr/share/fonts/X11/cyrillic​" does not exist.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/cyri​llic" does not exist.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/100d​pi/" does not exist.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/75dp​i/" does not exist.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/Type​1" does not exist.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/100d​pi" does not exist.
 (WW) The directory "/usr/X11R6/lib/X11/fonts/75dp​i" does not exist.
 (WW) The directory "/var/lib/defoma/x-ttcidfont-c​onf.d/dirs/TrueType" does not exist.
 (WW) NV(0): config file hsync range 28-64kHz not within DDC hsync ranges.
 (WW) NV(0): config file vrefresh range 43-60Hz not within DDC vrefresh ranges.
 (WW) (1280x960,Écran générique) mode clock 148.5MHz exceeds DDC maximum 110MHz
 (WW) (1280x1024,Écran générique) mode clock 135MHz exceeds DDC maximum 110MHz
 (WW) (1280x1024,Écran générique) mode clock 157.5MHz exceeds DDC maximum 110MHz
 (WW) (1600x1200,Écran générique) mode clock 162MHz exceeds DDC maximum 110MHz
 (WW) (1600x1200,Écran générique) mode clock 175.5MHz exceeds DDC maximum 110MHz
 (WW) (1600x1200,Écran générique) mode clock 189MHz exceeds DDC maximum 110MHz
 (WW) (1600x1200,Écran générique) mode clock 202.5MHz exceeds DDC maximum 110MHz
 (WW) (1600x1200,Écran générique) mode clock 229.5MHz exceeds DDC maximum 110MHz
 (WW) (800x600,Écran générique) mode clock 114.75MHz exceeds DDC maximum 110MHz
 (WW) (1792x1344,Écran générique) mode clock 204.8MHz exceeds DDC maximum 110MHz
 (WW) (1792x1344,Écran générique) mode clock 261MHz exceeds DDC maximum 110MHz
 (WW) (896x672,Écran générique) mode clock 130.5MHz exceeds DDC maximum 110MHz
 (WW) (1856x1392,Écran générique) mode clock 218.3MHz exceeds DDC maximum 110MHz
 (WW) (1856x1392,Écran générique) mode clock 288MHz exceeds DDC maximum 110MHz
 (WW) (928x696,Écran générique) mode clock 144MHz exceeds DDC maximum 110MHz
 (WW) (1920x1440,Écran générique) mode clock 234MHz exceeds DDC maximum 110MHz
 (WW) (960x720,Écran générique) mode clock 117MHz exceeds DDC maximum 110MHz
 (WW) (1920x1440,Écran générique) mode clock 297MHz exceeds DDC maximum 110MHz
 (WW) (960x720,Écran générique) mode clock 148.5MHz exceeds DDC maximum 110MHz
 (WW) (1152x864,Écran générique) mode clock 121.5MHz exceeds DDC maximum 110MHz
 (WW) (1400x1050,Écran générique) mode clock 122MHz exceeds DDC maximum 110MHz
 (WW) (1400x1050,Écran générique) mode clock 151MHz exceeds DDC maximum 110MHz
 (WW) (1400x1050,Écran générique) mode clock 155.8MHz exceeds DDC maximum 110MHz
 (WW) (1400x1050,Écran générique) mode clock 184MHz exceeds DDC maximum 110MHz
 (WW) (1680x1050,Écran générique) mode clock 147.14MHz exceeds DDC maximum 110MHz
 (WW) (1920x1200,Écran générique) mode clock 193.16MHz exceeds DDC maximum 110MHz
 (WW) (1920x1200,Écran générique) mode clock 230MHz exceeds DDC maximum 110MHz
 (WW) (960x600,Écran générique) mode clock 115MHz exceeds DDC maximum 110MHz
 (WW) (1920x1440,Écran générique) mode clock 341.35MHz exceeds DDC maximum 110MHz
 (WW) (960x720,Écran générique) mode clock 170.675MHz exceeds DDC maximum 110MHz
 (WW) (2048x1536,Écran générique) mode clock 266.95MHz exceeds DDC maximum 110MHz
 (WW) (1024x768,Écran générique) mode clock 133.475MHz exceeds DDC maximum 110MHz
 (WW) (2048x1536,Écran générique) mode clock 340.48MHz exceeds DDC maximum 110MHz
 (WW) (1024x768,Écran générique) mode clock 170.24MHz exceeds DDC maximum 110MHz
 (WW) (2048x1536,Écran générique) mode clock 388.04MHz exceeds DDC maximum 110MHz
 (WW) (1024x768,Écran générique) mode clock 194.02MHz exceeds DDC maximum 110MHz

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 13/02/2008 à 08:26:14  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
sauvegarde bien ton fichier xorg
 # cp /usr/X11/xorg.conf /usr/X11/xorg.conf.old

 -> Utilise l'utilitaire de nvidia pour te créer un xorg.conf  nvidia-settings.
 -> Ta carte video est elle ancienne? (c'est nvidia-kernel-legacy-source qu'il faut utiliser pour les vieilles cartes)
 -> Si ca marche pas poste le fichier xorg.conf  (.old)


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 13/02/2008 à 11:56:28  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Alors,

 Pêle mêle en récapitulant tout...

 j'ai bien un load glx dans la section modules et j'ai bien désinstallé le .run.

 Le problème est que lorsque je met "nvidia" à la place de "nv" dans le xorg.conf le serveur refuse de se lancer et dit qu'il ne trouve pas le driver. Or le module en question (c'est bien celui que je compile avec module assistant hein?) s'installe sans problème avec les commandes façon debian

 à savoir:

 [code]
 m-a prepare
 m-a a-i -i nvidia-kernel-source
 apt-get install nvidia-glx
 [/code]
 et ensuite un reboot.

 techniquement, ce que module assistant répond quand je lui demande de me traiter nvidia-kernel-source c'est:

 [code]
 Données de 1 paquets mises à jour
 Récupération des sources du noyau de la version : 2.6.18-6-686
 En-têtes du noyau disponibles dans /lib/modules/2.6.18-6-686/buil​d
 apt-get-y install build-essential

 Fait.
 unpack
 Extracting the package tarball, /usr/src/nvidia-kernel-source.​tar.bz2, please wait...
 Le fichier de paquet de destination
 /usr/src/nvidia-kernel-2.6.18-​6-686_169.09-1+2.6.18.dfsg.1-1​8etch1_i386.deb existe déjà, pas de
 reconstruction.
 (however, you could use the -f switch to ignore it)
 dpkg -Ei /usr/src/nvidia-kernel-2.6.18-​6-686_169.09-1+2.6.18.dfsg.1-1​8etch1_i386.deb
 Version 169.09-1+2.6.18.dfsg.1-18etch1 de nvidia-kernel-2.6.18-6-686 déjà installée, paquet ignoré.
 [/code]

 en gros que c'est déjà fait, et c'est vrai que j'ai du le taper une trentaine de fois en tout entre les différents tutos etc....

 donc, du coup j'ai une question:

 Si le module est bien compilé, installé gnagnagna et que xorg.conf ne le trouve pas, n'est ce pas parce qu'il est situé au mauvais endroit?
 Là visiblement d'après m-a il est là:
 [code]/usr/src/nvidia-kernel-2.​6.18-​6-686_169.09-1+2.6.18.df​sg.1-1​8etch1_i386.deb[/code]
 est un mauvais endroit? Est ce la raison pour laquelle xorg ne le trouve pas?

 Peut être dis je une énormité mais.... je n'y connais pas grand chose et je tente désespérément de faire marcher ma machine...

 par ailleurs un lsmod|grep nvidia renvoie cela:
 [code]
 nvidia               7815200  0
 i2c_core               19680  2 nvidia,i2c_i801
 agpgart                29896  2 nvidia,intel_agp
 [/code]
 cela signifie-t-il que le module de noyau est bien chargé?

 Merci de ton aide.

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 13/02/2008 à 14:56:24  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
peux tu renvoyer:
 $ ls -l /usr/src/linux  (pour vérifier le lien symbolique)
 $ find /lib/modules/   -name  nvidia.ko  (pour rechercher où est le module)


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 13/02/2008 à 15:57:25  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
alors:

 



ls -l /usr/src/linux
 lrwxrwxrwx 1 root src 35 2008-02-12 17:46 /usr/src/linux -> /usr/src/linux-headers-2.6.18-​6-686
 




 



 
 find /lib/modules/ -name nvidia.ko

 /lib/modules/2.6.18-6-686/nvid​ia
 /lib/modules/2.6.18-6-686/nvid​ia/nvidia.ko
 




  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 13/02/2008 à 16:10:01  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
donc le module est bien compilé, le lien symbolique est bon.

 Je pencherai vers une modif de xorg.conf
 après avoir sauvegardé ce fichier essaye nvidia-settings


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 13/02/2008 à 16:18:53  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
ben ça me dit command not found pour le nvidia-settings..........

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 13/02/2008 à 16:31:42  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
il faut installer
 nvidia-settings - Tool of configuring the NVIDIA graphics driver

 donc #  apt-get install nvidia-settings

 Il me vient une idée as tu dans ton xorg activé glx?
 $ cat /etc/X11/xorg.conf  |  grep glx
 si tu n'as rien alors il faut modifier ton xorg.conf pour ajouter  
 Load "glx"

 Tous les tutos que tu as du lire en parle.

 Poste ici ton xorg.conf


 edit xyclos c'est toi qui poste sur le forum debian?


---------------
gnu/debian lenny kernel 2.6.32
ragueubuff
Bébé forumeur (De 10 à 49 messages postés)
  1. Posté le 13/02/2008 à 17:03:34  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
effectivement tous les tutos en parlent et il est bien activé

 



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
 # nvidia-xconfig:  version 1.0  (randy@juliet2)  Fri Dec 30 21:53:37 PST 2005

 # /etc/X11/xorg.conf (xorg X Window System server configuration file)
 #
 # This file was generated by dexconf, the Debian X Configuration tool, using
 # values from the debconf database.
 #
 # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
 # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
 #
 # This file is automatically updated on xserver-xorg package upgrades *only*
 # if it has not been modified since the last upgrade of the xserver-xorg
 # package.
 #
 # If you have edited this file but would like it to be automatically updated
 # again, run the following command:
 #   sudo dpkg-reconfigure -phigh xserver-xorg

 Section "ServerLayout"

Identifier     "Default Layout"

Screen         "Default Screen" 0 0

InputDevice    "Generic Keyboard"

InputDevice    "Configured Mouse"
 EndSection

 Section "Files"

# path to defoma fonts

FontPath        "/usr/share/fonts/X11/misc"

FontPath        "/usr/X11R6/lib/X11/fonts/misc​"

FontPath        "/usr/share/fonts/X11/cyrillic​"

FontPath        "/usr/X11R6/lib/X11/fonts/cyri​llic"

FontPath        "/usr/share/fonts/X11/100dpi/:​unscaled"

FontPath        "/usr/X11R6/lib/X11/fonts/100d​pi/:unscaled"

FontPath        "/usr/share/fonts/X11/75dpi/:u​nscaled"

FontPath        "/usr/X11R6/lib/X11/fonts/75dp​i/:unscaled"

FontPath        "/usr/share/fonts/X11/Type1"

FontPath        "/usr/X11R6/lib/X11/fonts/Type​1"

FontPath        "/usr/share/fonts/X11/100dpi"

FontPath        "/usr/X11R6/lib/X11/fonts/100d​pi"

FontPath        "/usr/share/fonts/X11/75dpi"

FontPath        "/usr/X11R6/lib/X11/fonts/75dp​i"

FontPath        "/var/lib/defoma/x-ttcidfont-c​onf.d/dirs/TrueType"
 EndSection

 Section "Module"

Load           "bitmap"

Load           "dbe"

Load           "ddc"

Load           "extmod"

Load           "freetype"

Load           "glx"

Load           "int10"

Load           "record"

Load           "v4l"

Load           "vbe"

 EndSection

 Section "InputDevice"

Identifier     "Generic Keyboard"

Driver         "kbd"

Option         "CoreKeyboard"

Option         "XkbRules" "xorg"

Option         "XkbModel" "pc105"

Option         "XkbLayout" "fr"

Option         "XkbVariant" "latin9"
 EndSection

 Section "InputDevice"

Identifier     "Configured Mouse"

Driver         "mouse"

Option         "CorePointer"

Option         "Device" "/dev/input/mice"

Option         "Protocol" "ImPS/2"
 EndSection

 Section "Monitor"

Identifier     "Écran générique"

HorizSync       28.0 - 64.0

VertRefresh     43.0 - 60.0

Option         "DPMS"
 EndSection

 Section "Device"

Identifier     "nVidia Corporation G71 [GeForce 7900 GT/GTO]"

Driver         "nv"
 EndSection

 Section "Screen"

Identifier     "Default Screen"

Device         "nVidia Corporation G71 [GeForce 7900 GT/GTO]"

Monitor        "Écran générique"

DefaultDepth    24

SubSection     "Display"

Depth       1

Modes      "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x
 864" "1152x768" "1024x768" "800x600" "640x480"

EndSubSection

SubSection     "Display"

Depth       4

Modes      "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x
 864" "1152x768" "1024x768" "800x600" "640x480"

EndSubSection

SubSection     "Display"

Depth       8

Modes      "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x
 864" "1152x768" "1024x768" "800x600" "640x480"

EndSubSection

SubSection     "Display"

Depth       15

Modes      "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x
 864" "1152x768" "1024x768" "800x600" "640x480"

EndSubSection

SubSection     "Display"

Depth       16

Modes      "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x
 864" "1152x768" "1024x768" "800x600" "640x480"

EndSubSection

SubSection     "Display"

Depth       24

Modes      "1280x960" "1280x854" "1280x800" "1280x768" "1200x800" "1152x
 864" "1152x768" "1024x768" "800x600" "640x480"

EndSubSection
 EndSection

 




 oui je suis le xyclos de debian, je poste sur plusieurs forums pour maximiser les résultats. Ca m'a bien réussi pour le pb de son que tu avais résolu. Mais bon comme tu es le seul à m'aider sur ce forum et que l'autre sur lequel je suis ne sert à rien je suppose que si tu vas sur mon sujet de debian-forum je pourrai me contenter d'un seul forum.....

 le xorg.conf dit quelque chose?

 Je t'avouerais que je suis plus très loin d'installer fedora tout à fait entre nous... tu en penses quoi?

  1. homepage
limax
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 13/02/2008 à 21:42:17  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
ta debian c'est pour un usage personnel? un server? le boulot? etc...

 Sinon pour un usage personnel tu as avantage à passer de etch à lenny (voir la sid)

 Parce que pour ton problème je ne vois pas.


---------------
gnu/debian lenny kernel 2.6.32
zolinux
  1. Posté le 21/02/2008 à 18:48:11  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,

 Voilà je me suis lancé dans l'installation de Debian pour faire un basculement progressif de windows vers Linux, j'avais déjà entrepris l'opération il y a quelques années mais je n'avais pas été au bout car je n'ai pas pu me débarasser complétement de Windows. Aujourd'hui j'entreprend de nouveau la migration mais avec l'avantage d'avoir deux PC et de pouvoir en conserver un pour ce qui ne marcherait pas sous Linux... Bon tout cela pour vous évoquer mon problème qui ressemble très fortement à l'objet de ce post.

 En faite j'avais les mêmes symptômes pour l'installation des drivers nvidia et j'ai donc appliquer les solutions que vous évoquez, j'ai pu progresser mais j'ai bute actuellement sur un probleme lors du lancement du serveur X : startx

 J'obtiens les messages d'erreur suivants :
 



 
 (EE) Failed to load module nvidia (module does not exist, 0)
 (EE) No driver disponible
 Fatal server error:
 noscreen found
 ...
 




 En cherchant sur le net je suis tombé sur ce lien : http://wiki.debian.org/NvidiaG [...] #Libraries
 Et dans la section troubleshooting je trouve un passage qui correspond à mon pb et à ma configuration hardware, le voici :
 



Make sure that the file "nvidia_drv.o" is specified in the Xorg.0.log file, i.e that it has been loaded by X. If this file is not mentioned in the log file, then apply
 # cd /usr/lib/xorg/modules/drivers
 # /usr/lib/xorg/modules/drivers# gcc -shared nvidia_drv.o -o nvidia_drv.so
 




 Par cotre quand j'effectue cette commande j'obtiens le message d'erreur suivant que je ne sais pas interpréter

 



/usr/bin/ld: nvidia_drv.o Relocation R_X86_64_32S against 'a local symbol' can not be use when making a share object; recompile with -fPIC
 nvidia_drv.o could not read symbol: bad value
 Collect2:  ld returned 1 exit status




 Savez vous m'aider ?

 Pour info j'ai deja effectuée avec succes les commandes relative aux linux-headers, le decompactage du drivers, l'installation avec le module -assistant et le chargement du module au demarrage. J'ai aussi configuré Xorg (je suis pas sur de la configuration malgré tout)

zolinux
  1. Posté le 21/02/2008 à 20:03:20  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Debian car j'aime bien ce que cette distribution représente, la fiabilité, l'installation du juste nécessaire, sa politique vis à vis des marques.

 Lors de ma première expérience j'avais vraiment bien aimé sa gestion des paquets. D'autres distributions ont peut être le même principe...

 Par ailleur, je ne recherche pas spécialement la simplicité, sinon je resterais sous windows, c'est simple, connu et on est formatté à l'ergonomie depuis de longue année...

 Page :
1

Aller à :
 

Sujets relatifs
desinstallation linux Ubuntu pour debian [resolu] beug graphique avec les driver propio nvidia
OpenSUSE et drivers proprios nvidia Drivers GeForce 2 MX 400
cherche logiciel qui trouve ET installe les drivers seul drivers sur vista
Plus de sujets relatifs à : drivers nvidia sous debian 4.1

Les 5 sujets de discussion précédents Nombre de réponses Dernier message
sécurité 3
pb son sous Debian Etch 2
Transfer les données de ME à XP 0
Tomtom pour Typhoon my guide 3500 1
[Résolu] Réparer le Grub ? 3