Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business
  


  


  Calculer le nombre de personne ayant plusieurs critères

 

SECURITE : ange1277, 1 utilisateur anonyme et 193 utilisateurs inconnus
Ajouter une réponse

 Mot :  Pseudo :  
Vider la liste des messages à citer  
 Page :
1
Auteur
 Sujet :

Calculer le nombre de personne ayant plusieurs critères

Prévenir les modérateurs en cas d'abus 
n°1314214
Mopsos
Posté le 30-08-2006 à 04:25:49  answer
Prévenir les modérateurs en cas d'abus
 

Bonjour,
 Je recherche une formule me permettant de calculer le nombre de personne remplissants plusieurs critères précis...

 ==============================​==============================​====================
 Exp :
 Il y a des hommes et des femmes dans un marché.
 Il y a deux vendeurs de fruits
 Chaque vendeur à 3 type de fruits (ils sont assez limités :P)

 01/ H  Vendeur1  poire
 02/ H  Vendeur2  Poire
 03/ H  Vendeur1  poire
 04/ F  Vendeur2  Pêche
 05/ F  Vendeur2  Cerise
 06/ F  Vendeur1  Cerise
 07/ F  Vendeur1  Poire
 08/ H  Vendeur1  Cerise
 09/ H  Vendeur2  Cerise
 10/ F  Vendeur1  Pêche

 J'aimerai avoir une cellule qui me calcul automatiquement combien d'homme ont acheté chez le vendeur 1, des poires...

 En gros, je devrai obtenir ces résultats au final pour cet exemple :

 Nb D'homme : 5 (formule employée : NB.SI)
 Nb de femme : 5 (formule employée : NB.SI)

 Nb D'homme Vendeur1 : 3 (Formule recherchée)
 Nb de femme Vendeur1 : 3 (Formule recherchée)

 Nb D'homme Vendeur1 Poire : 2 (Formule recherchée)
 Nb D'homme Vendeur1 Pêche : 1 (Formule recherchée)
 Nb D'homme Vendeur1 Cerise : 2 (Formule recherchée)

 Nb de femme Vendeur1 Poire : 1 (Formule recherchée)
 Nb de femme Vendeur1 Pêche : 1 (Formule recherchée)
 Nb de femme Vendeur1 Cerise : 1 (Formule recherchée)


 Nb D'homme Vendeur2 : 2 (formule employée : NB.SI)
 Nb de femme Vendeur2 : 2 (formule employée : NB.SI)

 Nb D'homme Vendeur2 Poire : 1 (Formule recherchée)
 Nb D'homme Vendeur2 Pêche : 0 (Formule recherchée)
 Nb D'homme Vendeur2 Cerise : 1 (Formule recherchée)

 Nb de femme Vendeur2 Poire : 0 (Formule recherchée)
 Nb de femme Vendeur2 Pêche : 1 (Formule recherchée)
 Nb de femme Vendeur2 Cerise : 1 (Formule recherchée)
 ==============================​==============================​====================

 Je recherche les formules qui me permettrait d'automatiser ces calculs...

 Je sais que la formule "=NB.SI..." permet de sélectionner un critère (ou plusieurs si on la couple avec la fonction "=ET..." ) d'une seule colonne... mais comment fait-on pour dire 'je veux tel critère de telle colonne, mais aussi tel critère de telle colonne et tu me calcules combien il y en a qui remplissent les 2 critères"....

 Merci bcp pour votre aide.

 Mopsos

n°1314215
Pat Garett
Posté le 30-08-2006 à 06:33:16  answer
Prévenir les modérateurs en cas d'abus
 

Salut

 T'as pensé aux filtres élaborés?

n°1314216
qmike
Posté le 30-08-2006 à 07:26:18  answer
Prévenir les modérateurs en cas d'abus
 

bonjour
 regarde ici cet exemple via la fonction SOMME.SI
 http://bvrve.club.fr/Astuces_Michel/176excel.php

 Autre exemple avec la fonction SOMMEPROD
 http://bvrve.club.fr/Astuces_Michel/30excel.php

 Bonne journée


---------------
http://michel.vergriete.perso.sfr.fr//accueil.htm cordialement
n°1314217
Mopsos
Posté le 30-08-2006 à 10:23:45  answer
Prévenir les modérateurs en cas d'abus
 

Pat Garett > heu... Connait pas les filtres élaborés :P, tu peux m'en dire plus ? Je vais tout de même me renseigner de mon coté :-)

 Edit : après étude, les filtres élaborés ne me permettent que de trier les données... Moi ce qui m'intéresse, c'est de concerver une visibilité de mon tableau, que je remplis tous les jours, et donc que des statistiques se mettent en place automatiquement dans un tableau secondaire

 qmike > Les fonctions de somme ne peuvent pas fonctionner puisqu'il s'agit de données textuelles et non pas numérique...

 En fait, il me faidrait une fonction du type "Somme", pour des valeurs, avec des conditions... une sorte de SOMMEVAL.SI quoi... mais celle-ci n'existe pas, ou pas sous cette forme

n°1314218
qmike
Posté le 30-08-2006 à 15:05:42  answer
Prévenir les modérateurs en cas d'abus
 

e > Les fonctions de somme ne peuvent pas fonctionner puisqu'il s'agit de données textuelles et non pas

 La fonction SOMMEPROD peremet de travailler sur des données Textes

 Par ailleurs, tu as un exemple sur le lien cité plus haut


---------------
http://michel.vergriete.perso.sfr.fr//accueil.htm cordialement
n°1314219
toufik53
Posté le 30-08-2006 à 15:22:04  answer
Prévenir les modérateurs en cas d'abus
 

bonjour à tous, désolé de pourir votre sujet je ne sais pas comment en poster un, bref c'était juste pour savoir comment je pouvais enlever une page au nom de ad first load qui s'ouvre chaque  fois que j'utilise firefox

 merci

n°1314220
Mopsos
Posté le 30-08-2006 à 19:02:43  answer
Prévenir les modérateurs en cas d'abus
 

Ouais mais les Sommes, c'est pour cumuler... moi je veux que ça me calcule le nombre ayant le critère 2 dans ceux qui ont le critère 1...
 En gros : parmis les hommes, cb sont allés voir le vendeur 1, et que ça m'affiche le résultat directement dans la cellule comprenant la formule...

 Un "SOMME PROD" me cumulerait les personnes comprenant le critère 1 + le critère 2.

n°1314221
Lord Nelson
Posté le 30-08-2006 à 19:55:07  answer
Prévenir les modérateurs en cas d'abus
 

Salut,

 On n'imagine pas tout ce que peux faire SOMMEPROD !

 Par exemple :

 Nb D'homme Vendeur1 :
 =SOMMEPROD((A$1:A$10="H" )*(B$1​:B$10="Vendeur1" ))
 Nb de femme Vendeur1 :
 =SOMMEPROD((A$1:A$10="F" )*(B$1​:B$10="Vendeur1" ))
 Nb D'homme Vendeur1 Poire :
 =SOMMEPROD((A$1:A$10="H" )*(B$1​:B$10="Vendeur1" )*($C$1:$C$10=​"Poire" ))
 Nb D'homme Vendeur1 Pêche :
 =SOMMEPROD((A$1:A$10="H" )*(B$1​:B$10="Vendeur1" )*($C$1:$C$10=​"Pêche" ))
 Nb D'homme Vendeur1 Cerise :
 =SOMMEPROD((A$1:A$10="H" )*(B$1​:B$10="Vendeur1" )*($C$1:$C$10=​"Cerise" ))
 etc...

 A+
 Horatio

n°1314222
Mopsos
Posté le 30-08-2006 à 22:29:37  answer
Prévenir les modérateurs en cas d'abus
 

Lord, vous êtes à la grandeur de votre nom.. un grand merci :)

 Page :
1

Aller à :
Ajouter une réponse
  


  


  Calculer le nombre de personne ayant plusieurs critères

 

Sujets relatifs
Mettre plusieurs fichiers son bout à bout avec Audacitycherche la formule Exel pour calculer mes heures du travail
personne pour répondre à ma question déjà posée plus bas??nombre d'adresse dans msn (résolu)
excel: comment classer des lignes selon des critères?calculer un prix TTC
calculer un nombre de cellules excel[EXCEL] : comment calculer un écart entre deux dates ?
Calculer le nbre de jours ouvréscalculer le nombre de"cp" qu il y a sous excel
Calculer ses horaires avec Exel ? Le total des heures du mois ? UrgentLogiciel pour calculer le nombre de feuilles imprimées
recherche tableau sur excel permettant de calculer le TEG d'un emprunt 
Plus de sujets relatifs à : Calculer le nombre de personne ayant plusieurs critères

Les 5 sujets de discussion précédents Nombre de réponses Dernier message
Etrange bloquages dut à Word. 1 02-09-2006 à 08:06:28
clavier changeant 1 29-08-2006 à 19:30:03
télécharger dico espagol 5 01-09-2006 à 13:15:08
perdu contenu document! 0 29-08-2006 à 17:02:08
Page de démarrage 1 29-08-2006 à 14:49:49

Recevez toute
l’actu du forum !