Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business

|-  LOGICIELS


|||-  

Excel.Somme Si

 

ibizastweet
Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

Excel.Somme Si

RÉSOLU
Prévenir les modérateurs en cas d'abus 
BJ22
bj22
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 16/11/2018 à 13:33:48  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,

J' utilise dans Excel 10 la fonction Somme Si ci dessous!

=SOMME.SI($B$12:$G$65;B97;$E$1​2:$E$65)

La colonne de recherche ne contient que des nombres entiers.

Cette fonction fonctionne bien sauf quand la valeur des sommes à rechercher (B97) égale 8, j' obtient une valeur supérieure de 9.85.

J' ai fait des essais en supprimant toutes les valeurs de la clé 8, dans la colonne E, j' ai alors en résultat de 9.85.

J' appelle à l' aide car je ne m' en sort pas,
Merci pour l' aide:

willyplaisir
Expert Excel Habitué (de 5 000 à 9 999 messages postés)
  1. Posté le 16/11/2018 à 17:48:36  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
bsr Jean,

La syntaxe générale est la suivante =SOMMME.SI(plage_de_cellules;c​ritère;plage_à_totaliser)

ta cellule B97 (ligne 97 est sup à ligne 65) donc ça bug hors du champ
SOMME.SI($B$12:$G$65;B97;$E$1​​2:$E$65)

mettre plutôt
SOMME.SI($B$12:$G$97;B97;$E$1​​2:$E$97)

willy


---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
(Publicité)
bj22
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 16/11/2018 à 18:41:28  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonsoir,

Merci Willy, mais ce n' est pas la bonne réponse.

La plage de recherche est bonne, le critère de recherche 8, en cellule B97, est bien dans la plage de recherche en colonne B.

Je ne comprends pas pourquoi le résultat est supérieur de 9.85 somme qui n' apparait pas dans la plage en colonne E., qui ne comprend que des nombres entiers.

Je précise que le bug ne se produit que dans une feuille déterminée, les autres feuilles identiques dans la forme et formules fonctionnent bien.

J' ai fait une nouvelle feuille à partir d' une feuille qui fonctionne mais en mettant les coordonnées individuelles et les données de l' intéressé, le problème subsiste...

Cordialement,
BJ22

bj22
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 16/11/2018 à 19:04:08  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonsoir,

J' ai trouvé un palliatif pour résoudre provisoirement mon problème.

Dans la plage de recherche sur la ligne 40 colonne B j' ai mis le critère de recherche 8 et en colonne E la somme de - 9.85 (qui s' affiche - 10).

Cà fonctionne mais c' est du bricolage...

Cordialement,
BJ22

willyplaisir
Expert Excel Habitué (de 5 000 à 9 999 messages postés)
  1. Posté le 16/11/2018 à 19:27:32  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
bsr

peux-tu m'envoyer la feuille, uniquement celle qui contient ta formule dans un fichier pour voir ta formule et les colonnes de nombres.
@+ willy


---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
(Publicité)
bj22
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 20/11/2018 à 11:23:43  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Avec l' aide de Willy, que je remercie, j' ai résolu mon problème en rectifiant la formule: =SOMME.SI($B$12:$E$66;B97;$E$1​2:$E$66)

E66 au lieu de G66.

willyplaisir
Expert Excel Habitué (de 5 000 à 9 999 messages postés)
  1. Posté le 20/11/2018 à 11:37:34  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
content pour toi
@+ willy


---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
 Page :
1

Aller à :
 

Sujets relatifs
Excel colorer une ligne entière avec date dépassée en tenant compte des cases vi Microsoft Excel 2007 : avertissement
Excel Liste déroulante en cascade sans VBA Crèer une fonction Excel en complément
exel 2007 somme.si  
Plus de sujets relatifs à : Excel.Somme Si

Les 5 sujets de discussion précédents Nombre de réponses Dernier message
Excel colorer une ligne entière avec date dépassée en tenant compte des cases vi 8
Microsoft Excel 2007 : avertissement 3
Réinstallation d'OpenOffice.org impossible 2
Excel Liste déroulante en cascade sans VBA 6
Programmation VBA 6