Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business

|-  LOGICIELS


|||-  

Dénombrement dans Excel [résolu]

 

2 utilisateurs anonymes et 136 utilisateurs inconnus
Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

Dénombrement dans Excel [résolu]

Prévenir les modérateurs en cas d'abus 
f6ggr
f6ggr
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 06/05/2009 à 20:55:34  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,

 J'ai une colonne de cellules de E4 à E17 contenant les nombres 12, 12, 12, 23, 45, 45, 45, 45, 52, 56, 85, 74, 78, 85, 96.

 Trois nombres sont répétés : 12, 45 et 85.

 Comment faire pour calculer et trouver que 3 nombres sont répétés (une formule qui donne 3 comme résultat)?

 Merci.




---------------
ALAIN
  1. homepage
oligiera
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 07/05/2009 à 00:04:40  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
 Tu peux insérer une colonne à la droite de ta colonne E, et dans la première cellule, tu tapes : =B2&" "&COUNTIF($B$2:$B2;B2) *** faire attention à l'adressage absolu. ensuite tu copies cette formule dans toutes les autres cellules. Le résultat qui va s'incrire dans ta nouvelle colonne, va etre dans le genre "12-1, 12-2, 12-3, et 85-1, 85-2, etc" ..ensuite si tu veux tu peux classer cette colonne pour faciliter la lecture... Je n'ai rien trouvé de mieux, à moins de regarder du coté VBA, ce qui n'est pas mon fort......


---------------
aL1.
(Publicité)
willyplaisir
Expert Excel Habitué (de 5 000 à 9 999 messages postés)
  1. Posté le 07/05/2009 à 07:48:51  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
bonjour à tous,

 1) tu peux utiliser la fonction NB.SI
 mets dans la cellule F4:
 =NB.SI( $E$4:$E$17;F4) et tu recopies cette formule jusqu'à F17

 2) tu peux aussi te servir de la fonction Frequence
 dans la cellule F4
 =frequence(E4:E17;E4:E17) et tu valides en tapant sur les touches

 CTR+MAJ+Entrée pour obtenir la formule matricielle
 {=frequence(E4:E17;E4:E17)}

 et tu recopies cette formule jusqu'à F17

 cordialement  :salut:




---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
l'autre est mon miroir
bigdos
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 07/05/2009 à 07:50:40  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
:hello:
 j'ai cela si ça peut convenir:

 =SOMMEPROD(1*NB.SI(A:A;A1))
 tu l'incris en B1,
 puis tu cliques sur le coin droit de cette cellule un "+", que tu tires vers le bas, jusqu'ou tu veux que soient analysés tes nombres.

 :salut:

f6ggr
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 07/05/2009 à 09:42:07  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Merci beaucoup pour vos réponses.
 Mais je n'arrive pas à mon résultat qui doit me dire qu'il y a trois nombres distincts présentant des répétitions.

 Y-a-t-il une solution en dehors de VBA ?

 Je cherche aussi de mon côté.

 73


---------------
ALAIN
(Publicité)
f6ggr
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 07/05/2009 à 10:06:13  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
je viens de trouver la solution, sur Internet.

 Je vous donne l'adresse, car la formule est des plus ardue :

 Le site : "Developpez.com, le site des développeurs"

 http://silkyroad.developpez.co [...] ons/#LII-C

 Il y a sur ce site des tas de solutions (sans VBA) pour des calculs du genre.

 Merci à vous, merci à eux.


---------------
ALAIN
willyplaisir
Expert Excel Habitué (de 5 000 à 9 999 messages postés)
  1. Posté le 07/05/2009 à 20:42:42  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
:bien: Bravo
 quand on cherche....on trouve, merci pour l'info


---------------
[:ahlefoufou] Merci de sauver les chats abandonnés en aidant cette association : [:tazounet:5]
- Pension MillePattes
l'autre est mon miroir
bigdos
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 08/05/2009 à 08:35:25  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

 

f6ggr a écrit :

je viens de trouver la solution, sur internet.

 je vous donne l'adresse, car la formule est des plus ardue :

 le site : "developpez.com, le site des développeurs"

 http://silkyroad.developpez.co [...] ons/#lii-c

 il y a sur ce site des tas de solutions (sans vba) pour des calculs du genre.

 merci à vous, merci à eux.
 




 :hello:
 Merci pour ce renseignement,
 mais serait-il possible que tu m'indiques la formule,
 qui a répondu à ton souhait.

(Publicité)
f6ggr
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 08/05/2009 à 10:20:02  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Je voulais mettre l'image de la formule mais je n'y suis pas parvenu.

 La formule se trouve là :

 http://silkyroad.developpez.co [...] ons/#lii-c

 Chapitre III-B-3

 A plus


---------------
ALAIN
kensou
  1. Posté le 08/05/2009 à 16:13:24  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
 merci pour l'info. je dois admettre que tu es un bosseur   :hello:

l'autre est mon miroir
bigdos
Débutant confirmé (de 1 000 à 4 999 messages postés)
  1. Posté le 09/05/2009 à 16:47:40  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
:hello:
 ok et merci de ta recherche.
 :salut:

(Publicité)
 Page :
1

Aller à :
 

Sujets relatifs
EXCEL - trier une liste avec des images insérées excel : classer les feuilles/résolu
pb transfert de code postal d'excel a word excel: décalage automatique de texte dans colonne.
Comment fusionner un document Word avec Excel ? excel : formule pour calculer mes heures de travail
Plus de sujets relatifs à : Dénombrement dans Excel [résolu]

Les 5 sujets de discussion précédents Nombre de réponses Dernier message
gmail et hotmail 0
Joindre un fichier avec Gmail 5
Comment créer un nombre avec des lettres 3
recherche police avec mesures anglaises 2
PowerPoint perte du son (Lame MP3) 11