Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business

|-  INTERNET


|||-  

[resolu]Code php ne marche pas

 

bileg LOGICIELS : bernard53
Ajouter une réponse
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur
 Sujet :

[resolu]Code php ne marche pas

Prévenir les modérateurs en cas d'abus 
shiter
shiter
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 17/01/2007 à 08:20:33  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjours

 Voila j'ai juste un bout de code mais c'est pour la connexion à mysql que mon code foire alors qu'il semble être parfais !



 <?
 $CON = mysql_connect("localhost","roo​t","root" );
     mysql_select_bd("base_de_donne​e" );
   
 $titre = ($_POST['titre']);      //ici je recupere une variable dans une autre page, ça marche
 $article = ($_POST['article']);//ici je recupere une variable dans une autre page, ça marche  

 mysql_query("INSERT INTO articles VALUES('', '$titre', '$article')" );

 mysql_close($CON);
 ?>


 J'ai aussi essayer en mettant : ('','" . $titre . ", '" . $article . "') mais ça ne marche pas nonplus

 Merci d'avance


---------------
Yeaaaaaar le site innove, venez tous !!! XD
guiii
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 17/01/2007 à 11:59:54  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Bonjour,

 t'as un message d'erreur, quelque chose ?

 C'est pas au niveau de la connexion, mais au niveau de l'insertion que ça ne marche pas, plutôt ?

 Quels sont les champs de ta table articles ?


 



$titre = ($_POST['titre']);



 l'intérêt des paranthèse à ce niveau-là ?

(Publicité)
shiter
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 17/01/2007 à 14:10:09  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
Non j'ai rien puisque j'ai rien demander d'afficher, mais ça n'envoie pas $titre et $article jusqu'à la base de donnée.

 Sinon c'est bien au niveau de la connexion car lorsque je met  <? echo "$article" ?>  ça fonctionne


---------------
Yeaaaaaar le site innove, venez tous !!! XD
guiii
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 17/01/2007 à 16:23:18  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

shiter a écrit :

Non j'ai rien puisque j'ai rien demander d'afficher, mais ça n'envoie pas $titre et $article jusqu'à la base de donnée.

 Sinon c'est bien au niveau de la connexion car lorsque je met  <? echo "$article" ?>  ça fonctionne
 



 Si tu es sûr de tes identifiants, c'est que le problème ne vient pas de la connexion, mais bien de l'insertion.
 Fais au moins un test de lecture dans ta table articles. Si ça marche c'est que le problème est ailleurs.

 Ta table s'appelle bien articles avec un "s" et ne comporte que 3 champs, dont le premier est en auto_increment ?

shiter
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 17/01/2007 à 18:32:50  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
hé bien justement, c'est ce que je disais, le code est parfais mais pas moyen de le faire marcher ^^.

 J'ai verifier plusieurs fois le nom de ma table, le nombre de colone tout est nickel.

 Je pense que ça doit peut-être merder au niveau de

 mysql_query("INSERT INTO articles VALUES('', '$titre', '$article')" );

 Parce que c'est la seule ligne que je n'ai jamais fait.

 Aaaaarg, mon code est parfais c'est ch***


---------------
Yeaaaaaar le site innove, venez tous !!! XD
(Publicité)
poulbot
Habitué (de 5 000 à 9 999 messages postés)
  1. Posté le 18/01/2007 à 14:13:07  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 

shiter a écrit :

 
 mysql_select_bd("base_de_donne​e" );
 



 Bonjour,

 Essaie :
 mysql_select_db("base_de_donnee" );

 cordialement


---------------
(◕_◕)
shiter
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 21/01/2007 à 08:59:59  
  1. answer
  1. Prévenir les modérateurs en cas d'abus
 
J'ai essayer ça marche ! ^^ quand je pense que je suis rester des jours et des jours sur ce code pour 2 lettres inversées arrrg !

 Merci beaucoup je vais enfin pouvoir avancer ! Merci


---------------
Yeaaaaaar le site innove, venez tous !!! XD
 Page :
1

Aller à :
 

Sujets relatifs
problème d'importation de Favoris vers Firefox [Résolu] cherche code free wifi
Problème internet? [Résolu] [Résolu]Conseil pour un nom de domaine
Les ondes émises par la LIVEBOX.....RESOLU Problème transmetteur audio-vidéo sans fil [résolu]
mon réseau marche dans un sens  
Plus de sujets relatifs à : [resolu]Code php ne marche pas

Les 5 sujets de discussion précédents Nombre de réponses Dernier message
Codes des messages sur les forums ! 2
installation wordpress sur lycos 0
construction site 7
NVU et 12mix 6
Pub sauvage latérale 3