Actualité informatique
Test comparatif matériel informatique
Jeux vidéo
Astuces informatique
Vidéo
Télécharger
Services en ligne
Forum informatique
01Business



|||-  

Commande DOS sous Vista : Protection des noms avec espaces

 

g113 et 2 utilisateurs anonymes
 

 
Page photos
 
     
Vider la liste des messages à citer
 
 Page :
1
Auteur Sujet :

Commande DOS sous Vista : Protection des noms avec espaces

Sybren
sybren
  1. Posté le 24/12/2007 à 09:13:43  
 
Bonjour,

 Je veux utiliser la commande DOS ROBOCOPY pour copier des dossiers avec des noms longs (exemple "Mes sites Web" ). C'est pour plannifier une tâche de sauvegarde. Comment protéger ces noms car DOS n'accepte pas les espaces. J'ai essayé des "", mais ça ne marche pas. Quelqu'un pouurait il m'aider?

 Merci et cordialement,

 Sybren

(Publicité)
  1. homepage
oligiera
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 24/12/2007 à 15:43:15  
 
 Probablement une erreur de syntaxe.
  Peux-tu copier / coller le genre de command que tu veux faire éxécuter, ça serait plus facile de voir ou est le problème.

 bye, ;)

sybren
  1. Posté le 26/12/2007 à 12:32:26  
 
Bonjour,

 Voilà un exemple:
 robocopy C:\Users\Alain\Documents\"Docu​ments à conserver"\ D:\Sauvegardes\ /E /PURGE

 Merci de m'aider,

 Sybren

prog2
Sur la bonne voie (de 100 à 499 messages postés)
  1. Posté le 26/12/2007 à 15:18:55  
 
Bonjour

 Parce que les "" sont à mettre autour du dossier complet, comme
 robocopy "C:\Users\Alain\Documents à conserver\" "D:\Sauvegardes\" /E /PURGE

 Ravi d'apporter assistance

sybren
  1. Posté le 27/12/2007 à 20:59:19  
 
Bonjour,

 Ce n'est pas bon, il y a toujours erreur dans les noms.

 Cordialement,

 Sybren

  1. homepage
oligiera
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 28/12/2007 à 00:53:56  
 
 essaie ceci:

C:\Users\Alain\Documents"\Docu​ments à conserver" D:\Sauvegardes\ /E /PURGE

J'ai déplacé les guillements et supprimé un slash............

 Une façon de vérifier si la syntaxe est la bonne, pour la première partie, est de taper, au DOS Prompt: cd "\users\alain\documents"\docum​ents à conserver", (en autant que tu n'est pas déjà dans ce directory)et tu verras tout de suite si tu atteris là ou tu devrais.  

 Feedback svp....
 bye,
 ;)    

sybren
  1. Posté le 29/12/2007 à 18:25:19  
 
Bonjour,

 Ca marche avec un "mais". Car il faut que je sorte le caractère accentué "à".

 Voilà la commande (c'est un exemple):
 robocopy C:\Users\Alain\Documents"\Docu​ments à conserver"\ C:\Users\Alain\Desktop\Toto /E 1> Robot.txt

 Voilà le CR:
 D‚but : Sat Dec 29 18:18:10 2007

Source : C:\Users\Alain\Documents\Docum​ents à conserver\

Dest : C:\Users\Alain\Desktop\Toto\

Fichiers : *.*
     
  Options : *.* /S /E /COPY:DAT /R:1000000 /W:30

 ------------------------------​------------------------------​-------------------

 2007/12/29 18:18:10 ERREUR 2 (0x00000002) AccŠs au r‚pertoire source C:\Users\Alain\Documents\Docum​ents à conserver\
 Le fichier sp‚cifi‚ est introuvable.

 Pourtant, il mentionne bien les dossiers Source et Dest.

 Si je renomme le dossier en "Documents conserver", il fait la copie. Si je remets le "à", ça ne marche pas.

 Connais tu ce qu'il faut faire pour protéger les caractères accentués?

 Merci et cordialement,

 Sybren

  1. homepage
oligiera
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 30/12/2007 à 01:20:44  
 
 Bon, j'ai fait des tests, et tout fonctionne normalement avec edlin(CMD), mais il se peut qu'a l'intérieur de batch file, la syntaxe soit plus picky....
  Tu peux essayer avec cette variante:

 



C:"\Users\Alain\Documents\Docu​ments "à" conserver"




  Une autre alternative interessante et peu connu: utiliser les équivalents donnés par MS DOS pour les mots (soit directory ou fichier) avec des charactères accentués. La syntaxe est, disons pour le directory "users", C:\users>Dir /x
  Ci-joints deux liens pour des exemples:
  http://img174.imageshack.us/im [...] ntbbk4.jpg

 et :
  http://img166.imageshack.us/im [...] t2bog6.jpg

  Espérant que ça va résoudre le problème...
 bye, ;)

sybren
  1. Posté le 31/12/2007 à 09:35:26  
 
Bonjour,
 Merci pour la solution d'utiliser les noms courts MS-DOS. Ca marche.
 J'ai cerné le PB. Avec l'invite DOS, la commande avec le nom long "\Documents à conserver" fonctionne sans problème. Mais c'est avec un fichier texte .batch que ça ne fonctionne pas. Je ne comprends vraiment pas pourquoi.

 Merci de m'avoir aidé et cordialement,

 Sybren

  1. homepage
oligiera
Tu cartonnes ! (de 500 à 999 messages postés)
  1. Posté le 31/12/2007 à 22:52:54  
 
 Content de voir que ça a réglé le problème.
 bye,
 ;)

 Page :
1

Aller à :